Hi all plugin authors,
On Thu, 3 Jan 2008 12:31:06 -0600
"Jeff Pohlmeyer" <yetanothergeek at gmail.com> wrote:
IMO, the names from pluginmacros.h should be all
I know this will break all of the existing plugins, but I think it is
much better in the long run, it makes the code more readable,
at least for me.
I've committed alternative macros in pluginmacros.h that use a 'p_'
prefix, instead of all uppercase. Enrico & I think this is more
readable and consistent. The macro names after the prefix are the same
as the first word in the core function name - e.g.:
document_open_file() -> p_document->open_file()
The variable name macros are unaffected.
The old macros will still be available in pluginmacros.h until after the
next release, so there is no rush to update external plugins, but it is
advisable to do so when you can.
Please let me know if there are any problems with this.