Le 18/03/2013 20:46, יוסף אור בוצ'קו a écrit :
See new patch.
[...]
From 3b3c3dbaf0d401a3001a49d4a018e84648ad51ef Mon Sep 17 00:00:00 2001 From: Yosef Or Boczko yosefor3@walla.com Date: Mon, 18 Mar 2013 21:42:47 +0200 Subject: [PATCH] GTK3 support for GeanyPrj
build/geanyprj.m4 | 3 ++- geanyprj/src/menu.c | 6 ++++-- 2 files changed, 6 insertions(+), 3 deletions(-)
diff --git a/build/geanyprj.m4 b/build/geanyprj.m4 index 4c11ab4..8d68324 100644 --- a/build/geanyprj.m4 +++ b/build/geanyprj.m4 @@ -1,8 +1,9 @@ AC_DEFUN([GP_CHECK_GEANYPRJ], [ GP_ARG_DISABLE([GeanyPrj], [auto])
- GP_CHECK_PLUGIN_GTK2_ONLY([GeanyPrj])
- GP_COMMIT_PLUGIN_STATUS([GeanyPrj])
I'd rather not see these empty lines changes.
AC_CONFIG_FILES([ geanyprj/Makefile geanyprj/src/Makefile
diff --git a/geanyprj/src/menu.c b/geanyprj/src/menu.c index 42cc61e..ffb1c41 100644 --- a/geanyprj/src/menu.c +++ b/geanyprj/src/menu.c @@ -26,6 +26,8 @@ #endif #include <geanyplugin.h>
+#include <gtkcompat.h> /* for the GTK+ 3 support */
BTW I don't know if the naming I used to that header is correct, since it uses the "gtk" prefix... maybe I should rename it, it anybody got a better name I'm all ears.
#include "geanyprj.h"
PluginFields *plugin_fields; @@ -180,9 +182,9 @@ static PropertyDialogElements *build_properties_dialog(gboolean properties) label = gtk_label_new(_("Type:")); gtk_misc_set_alignment(GTK_MISC(label), 1, 0);
- e->type = gtk_combo_box_new_text();
- e->type = gtk_combo_box_text_new(); for (i = 0; i < NEW_PROJECT_TYPE_SIZE; i++)
gtk_combo_box_append_text(GTK_COMBO_BOX(e->type), project_type_string[i]);
gtk_combo_box_text_append_text(GTK_COMBO_BOX_TEXT(e->type), project_type_string[i]);
gtk_combo_box_set_active(GTK_COMBO_BOX(e->type), 0);
ui_table_add_row(GTK_TABLE(table), 4, label, e->type, NULL);
-- 1.8.2