On Tue, 11 May 2010 22:17:43 +0200 (CEST), Colomban wrote:
Hi there!
It was something I would do since a while, and there it is finally: making the class builder plugin generate GTK+ classes that better follows GObject naming conventions. I think of NAMESPACE_TYPE_CLASS_NAME instead of CLASS_NAME_TYPE, NAMESPACE_IS_CLASS_NAME instead of IS_CLASS_NAME, etc. The missing thing was mostly a separated namespace in facts.
Great.
Then, as usual there's a path. Oh no, two patches.
0001-classbuilder-no-document-sensitive.patch: A very small patch that makes then plugin's menu document-insensitive. I don't see any reason for the menu to be document sensitive, and it obviously disallow to use the plugin when no document is open -- quite strange since it only /crates/ files.
Probably just another copy&paste mistake, not sure. Anyway, patch committed.
0001-classbuilder-gtk-class-improvements.patch: This one is the actual interesting stuff. What's in:
- namespace support (optional, leaving it empty works);
- GET_CLASS() macro;
- typedef of the private structure in the .h instead of declaring it;
- removing of the extra ";" at the end of G_DEFINE_TYPE().
Also committed, thanks.
Regards, Enrico