[Geany-devel] API: headers / GeanyEditor / gint idx
enrico.troeger at xxxxx
Wed Jun 11 17:09:39 UTC 2008
On Wed, 11 Jun 2008 18:03:37 +0100, Nick Treleaven
<nick.treleaven at btinternet.com> wrote:
> On Tue, 10 Jun 2008 18:01:57 +0200
> Enrico Tröger <enrico.troeger at uvena.de> wrote:
> > Honestly, I don't care much. Yes, it would be nicer if they were all
> > named using a unique scheme. But this causes renaming, changing
> > files where the file names are used, may result in odd left-overs
> > or other potential problems which aren't really necessary (ok,
> > probably it's not that much work, but it is also not really a big
> > problem at all). If you feel really uncomfortable with that, feel
> > free to change it. If not, I don't care.
> OK, I'll leave it. Do you have any preference for any new files I
> might add in future: newfile.h new-file.h new_file.h? I guess the rule
> could be to use the first one unless the name is confusing, like
> uiutils would be - in those cases, use underscores. Probably I'll
This what I thought. As long as it stays readable, no separation
characters, and otherwise, use an underscore. That's what I'd prefer.
> rename the plugin-symbols.c file as this seems to be the exception,
> as tm_source_file.h uses underscores.
Get my GPG key from http://www.uvena.de/pub.asc
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Size: 189 bytes
Desc: not available
More information about the Devel