[Geany-devel] API: headers / GeanyEditor / gint idx
nick.treleaven at xxxxx
Wed Jun 11 17:03:37 UTC 2008
On Tue, 10 Jun 2008 18:01:57 +0200
Enrico Tröger <enrico.troeger at uvena.de> wrote:
> Honestly, I don't care much. Yes, it would be nicer if they were all
> named using a unique scheme. But this causes renaming, changing files
> where the file names are used, may result in odd left-overs or other
> potential problems which aren't really necessary (ok, probably it's
> not that much work, but it is also not really a big problem at all).
> If you feel really uncomfortable with that, feel free to change it. If
> not, I don't care.
OK, I'll leave it. Do you have any preference for any new files I
might add in future: newfile.h new-file.h new_file.h? I guess the rule
could be to use the first one unless the name is confusing, like
uiutils would be - in those cases, use underscores. Probably I'll
rename the plugin-symbols.c file as this seems to be the exception,
as tm_source_file.h uses underscores.
> > I'd thought maybe we could rename document.[hc] documents.[hc] - or
> > would you prefer not to? I'm not sure but it might be more
> > consistent with filetypes.c, using the plural rather than singular.
> I remember I chose the singular 'document' (long time ago :D) based on
> the content this file should have: the document struct to represent an
> open document in Geany and related functions which work on one
> document 'object'. This were never really consistent done but mostly.
> And except for a few functions like document_close_all or
> document_open_files, this still applies, IMO. So, I would rather keep
> it as it is.
OK, no problem.
More information about the Devel