[Geany-Users] Upgrading geany in Ubuntu 16.04 wants to remove geany-plugin-git-changebar :(

Andrew Kennedy andrew_kennedy7 at xxxxx
Thu Mar 14 20:19:48 UTC 2019

I forgot how to make a post in the Geany forum?
Thanks,               Andy

Sent via personal computer"It is always too soon to quit."

    On Thursday, March 14, 2019, 2:39:28 PM CDT, Abel <akronix5 at gmail.com> wrote:  
I'm using Ubuntu 16.04 (I know, pretty old, but still supported). I run apt upgrade and I got this message:
The following packages have unmet dependencies:
 geany-plugin-git-changebar : Depends: libgit2-22 (>= 0.22.0) which is a virtual package and is not provided by any available package.

The following actions will resolve these dependencies:

     Remove the following packages:
1)     geany-plugin-git-changebar  
2)     geany-plugins     

However, if I query my installed libgit it is greater than 0.22:
> $ dpkg -l | grep libgit                                                                                                                
ii  libgit2-24:amd64                                            0.24.1-2ubuntu0.2                               amd64        low-level Git library
ii  libgit2-glib-1.0-0:amd64                                    0.24.0-3                                        amd64        glib wrapper library around the libgit2 git access library

I want to keep geany-plugin-git-changebar. I'd say it is my most wanted plugin of Geany actually. How can I workaround this?


Users mailing list
Users at lists.geany.org
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.geany.org/pipermail/users/attachments/20190314/9653a738/attachment.html>

More information about the Users mailing list