[Geany-Users] Upgrading geany in Ubuntu 16.04 wants to remove geany-plugin-git-changebar :(
lists.ban at xxxxx
Thu Mar 14 21:25:33 UTC 2019
Le 14/03/2019 à 20:38, Abel a écrit :
> I'm using Ubuntu 16.04 (I know, pretty old, but still supported). I run
> apt upgrade and I got this message:
> The following packages have unmet dependencies:
> geany-plugin-git-changebar : Depends: libgit2-22 (>= 0.22.0) which is a
> virtual package and is not provided by any available package.
> The following actions will resolve these dependencies:
> Remove the following packages:
> 1) geany-plugin-git-changebar
> 2) geany-plugins
> However, if I query my installed libgit it is greater than 0.22:
Unfortunately you have libgit2-24, which is not the same as libgit2-22.
Current plugin is however compatible with both, so Ubuntu only has to
In any case, we don't make the Ubuntu packages, so it's better to report
these kind of issues to the packages authors. If it comes straight from
Ubuntu, see with them, and if it comes from the Ubuntu Geany PPA see
with the maintainer there (CC'd in case).
> I want to keep geany-plugin-git-changebar. I'd say it is my most wanted
> plugin of Geany actually. How can I workaround this?
At worse, you could build the plugin yourself, it shouldn't be much
trouble, and we'd be happy to provide guidance there if needed.
More information about the Users