[Geany-Users] New geany package requirements

Asif Aaron Amin asifamin at xxxxx
Fri Nov 18 20:34:32 UTC 2016


When I try to build the latest geany (version 1.29) from source I get the
following configure error:

checking for GTK... no
configure: error: Package requirements (gtk+-2.0 >= 2.24 glib-2.0 >= 2.32
gio-2.0 >= 2.32 gmodule-no-export-2.0) were not met:

Requested 'glib-2.0 >= 2.32' but version of GLib is 2.28.8
Requested 'gio-2.0 >= 2.32' but version of GIO is 2.28.8

Is it possible to get past these constraints besides installing the latest
glib libraries? I'm currently using version 1.27 and I was able to build
from source flawlessly. I feel bad that I'm not using the bleeding edge
geany version anymore. Geany is my favorite text editor and I like to get
the new goodies from each new release.

If it matters my OS is RHEL 6.

Thanks for all your help!
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.geany.org/pipermail/users/attachments/20161118/24d03cfa/attachment.html>

More information about the Users mailing list