[Geany-Users] Difficulty installing spellcheck plugin on geany

ripspin-005 at yahoo.com.au ripspin-005 at xxxxx
Mon Sep 30 09:28:19 UTC 2019

to Users
I have been trying to install the spellcheck plugin, and I am finding it quite hard.
I have got to the point of downloading the github zip file at: https://github.com/geany/geany-plugins and running autogen.sh. This fails saying I have version 1.27 but I have version 1.35. Here are the printouts:
(I am running xenialpup (xenial64_7-5-5 puppylinux))

type -a geany
geany is /usr/local/bin/geany
/usr/local/bin/geany -V
geany 1.35 (git >= bf5c9ed) (built on 2019-01-31 with GTK 2.24.30, GLib 2.48.2)
You should update your 'aclocal.m4' by running aclocal.
autoreconf: Entering directory `.'
autoreconf: configure.ac: not using Gettext
autoreconf: running: aclocal --force -I build/cache -I build -I build/bundled -I geanypy/m4 --install
autoreconf: configure.ac: tracing
autoreconf: running: libtoolize --copy --force
....Not included........
checking for msgfmt... (cached) /usr/bin/msgfmt
checking for dcgettext... yes
checking if msgfmt accepts -c... yes
checking for gmsgfmt... (cached) /usr/bin/msgfmt
checking for xgettext... (cached) /usr/bin/xgettext
checking for catalogs to be installed...  be ca da de el es fr gl it ja kk nl pt pt_BR ru tr zh_CN
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for GEANY... no
configure: error: Package requirements (geany >= 1.29) were not met:

Requested 'geany >= 1.29' but version of Geany is 1.27

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables GEANY_CFLAGS
and GEANY_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

uname -a
Linux xenial64-sda1 4.9.58 #1 SMP PREEMPT Mon Nov 13 15:54:01 GMT 2017 x86_64 x86_64 x86_64 GNU/Linux

Should I report this as a bug?

Regards Garthur

More information about the Users mailing list