[Geany-Users] Upgrading geany in Ubuntu 16.04 wants to remove geany-plugin-git-changebar :(
akronix5 at xxxxx
Fri Mar 15 09:17:17 UTC 2019
On Thu, 14 Mar 2019 at 22:26, Colomban Wendling <lists.ban at herbesfolles.org>
> Hello Abel,
> Le 14/03/2019 à 20:38, Abel a écrit :
> > I'm using Ubuntu 16.04 (I know, pretty old, but still supported). I run
> > apt upgrade and I got this message:
> > The following packages have unmet dependencies:
> > geany-plugin-git-changebar : Depends: libgit2-22 (>= 0.22.0) which is a
> > virtual package and is not provided by any available package.
> > The following actions will resolve these dependencies:
> > Remove the following packages:
> > 1) geany-plugin-git-changebar
> > 2) geany-plugins
> > However, if I query my installed libgit it is greater than 0.22:
> Unfortunately you have libgit2-24, which is not the same as libgit2-22.
> Current plugin is however compatible with both, so Ubuntu only has to
> rebuild it.
> In any case, we don't make the Ubuntu packages, so it's better to report
> these kind of issues to the packages authors. If it comes straight from
> Ubuntu, see with them, and if it comes from the Ubuntu Geany PPA see
> with the maintainer there (CC'd in case).
It comes from the PPA indeed, exactly this one:
I can't see anyone CC'ed :S
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the Users