[Geany] Geany gtk2 requirements to configure ubuntu
elextr at xxxxx
Sun Nov 13 04:56:13 UTC 2011
On Sun, Nov 13, 2011 at 3:19 PM, Sayth Renshaw <flebber.crue at gmail.com> wrote:
> I am trying to use the ./configure option to install geany 0.21 on ubuntu. I
> am getting an error that the gtk dependencies aren't met. I think it may
> just be the naming of the dependencies that is stopping it . Any idas on how
> to get round it.
> The error configure: error: Package requirements (gtk+-2.0 >= 2.12 glib-2.0
>>= 2.16 gio-2.0 >= 2.16) were not met:
As Matthew said you need the development package if you are compiling,
> No package 'gtk+-2.0' found
> However I searched and found that all were installed just in the name format
> of gir1.2-gtk-2.0 (see below) the same holds true for glib and gio.
For your information these are not the GTK packages by another name,
they are introspection data for the GTK interface. You still need the
libgtk2.0 packages themselves, which the dev package above will get.
More information about the Users