[Geany] Geany gtk2 requirements to configure ubuntu

Sayth Renshaw flebber.crue at xxxxx
Sun Nov 13 04:19:33 UTC 2011

I am trying to use the ./configure option to install geany 0.21 on ubuntu.
I am getting an error that the gtk dependencies aren't met. I think it may
just be the naming of the dependencies that is stopping it . Any idas on
how to get round it.

The error configure: error: Package requirements (gtk+-2.0 >= 2.12 glib-2.0
>= 2.16 gio-2.0 >= 2.16) were not met:

No package 'gtk+-2.0' found

However I searched and found that all were installed just in the name
format of gir1.2-gtk-2.0 (see below) the same holds true for glib and gio.

sayth at sayth-TravelMate-5740G:~/Downloads/geany-0.21$ sudo apt-get install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Note, selecting 'gir1.2-gtk-2.0' for regex 'gir1.2-gtk-2'
gir1.2-gtk-2.0 is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Any ideas how to make configure complete?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.geany.org/pipermail/users/attachments/20111113/c827c71c/attachment.html>

More information about the Users mailing list