[Geany-Devel] Building geany using msys2 on Windows 10

Enrico Tröger enrico.troeger at xxxxx
Sun Sep 12 12:13:33 UTC 2021


>>> The test installers are ready:
>>> https://download.geany.org/snapshots/geany-1.38beta1_setup.exe
>>> https://download.geany.org/snapshots/geany-plugins-1.38beta1_setup.exe
>> Thanks. I downloaded and installed both of these. So far they have
>> worked flawlessly, although I have not done much actual work, instead,
>> just re-exploring the interface and preferences.
>> I have a few observations, questions and suggestions.

Thanks for testing and your feedback!

>> - the slow project loading of 1.37.1 is corrected.


>> - the visual style of scrollbars on the edit window is different. The
>> scrollbars are now about half the width as formerly. The previous
>> scrollbars were about twice as wide, making it much easier to grab the
>> thumb. The Win10 style is a narrow scrollbar that gets wider when you
>> hover over them. Is it possible to have a choice, or at least an OS
>> style scrollbar?
> I assume you mean the scrollbars on the edit window, those are drawn
> by the Scintilla editing widget Geany uses, and AFAICT its API gives
> no way of setting that width.

I think this is rather the GTK3 default theme.
Attached are three screenshots of Geany with:
- the default theme (I assume it's Adwaita)
- the native "win32" theme
- a theme from https://www.gnome-look.org/p/1013580/ called "Windows10",
it's more compact than the default theme

Doug, might you share a screenshot of "your" Geany? :)

>> - The help button does not work on any preference page. It reports, e.g.:
>>   21:16:09: Failed to open URI "C:/Program
>> Files/Geany/share/doc/geany/html/index.html#various-preferences": The
>> system cannot find the file specified.
>>  And in the Debug Messages:
>>  21:16:14: Geany WARNING    : ShellExecute failed opening "C:/Program
>> Files/Geany/share/doc/geany/html/index.html#various-preferences" (code
>> 2): The system cannot find the file specified.
> Did you check if the file exists?  Or has been installed to a
> different location?
>>   The menu item "Help->help" and pressing "F1" correctly open the help
>> file in Firefox Nightly at
>>   "file:///C:/Program%20Files/Geany/share/doc/geany/html/index.html"
> Not sure why this uses a different method to the other help, although

It's the same method and that's part of the problem.
Opening URIs works pretty fine from within Geany except they contain
There is already an issue for it with all the boring details:

>> - The help file does not declare its character encoding so the 3rd
>> non-blank line contains "Authors: Enrico Tröger".
> The 4 th line of the help file should be:
> <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
> so it should open as UTF-8, maybe something went wrong in the building?

Yes, the charset header is fine the broken characters are already
wrongly written into the generated HTML. I will have a look at it.

>> - The menu item "Tools->Load Tags File..." uses a non-windows style
>> file search dialog.
> You can make an issue for that, but probably somebody will have to
> contribute the code for it.

As said in https://github.com/geany/geany/issues/1942, I'd rather vote
for removing the native dialogs.

>> - The menu item "Help->Debug Messages" opens a very small window.
>> Opening the window with a size of relative to the main geany window,
>> or perhaps safer, relative to the screen size would be nice. Some

Agreed. Not sure whether it's worth the efforts. This dialog is usually
not opened regularly.
Btw, this is not Windows specific, it's the same behavior on all platforms.

>> messages do not have the timestamp prefix. Many debug messages have
>> the same time stamp, so adding the milliseconds value would be
>> helpful.
> Request a feature addition, although I think the timestamp is added by
> Glib, so we might not be able to control it.

We are and we had https://github.com/geany/geany/pull/2659 for it.
It's now merged and will be included in the next build.

Do you have examples of messages without timestamps?
I see messages like:
10:58:28: GLib-GIO DEBUG	: Collecting capable appnames: 0ms
Allocating hashtables:...... 0ms
Reading capable apps:        32ms
Reading URL associations:... 0ms
Reading extension assocs:    78ms
Reading exe-only apps:...... 46ms
Reading classes:             266ms
Reading UWP apps:            0ms
TOTAL:                       422ms

But this seems to be one single message just with line breaks.

>> - The keybinding for entering unicode characters is documented, but
>> the key combo Ctrl-Shift-u does not seem to work at all in 1.38beta1.
>> The ability to enter unicode characters is almost a requirement for
>> me.

It's just different on Windows.



I guess one those methods might work. I wasn't able to get it working
even in Notepad but I might not have tried hard enough (and I didn't
logged out after adding the registry key).
If you find a working way, we could update the documentation.

>> - Geany on Win10 can be crashed every time by opening the open file
>> dialog, shift-right-click on a filename and selecting "Copy as path".

Let's discuss this in https://github.com/geany/geany/issues/1942


Get my GPG key from https://www.uvena.de/pub.asc
-------------- next part --------------
A non-text attachment was scrubbed...
Name: geany_windows_theme_Windows10.png
Type: image/png
Size: 42040 bytes
Desc: not available
URL: <https://lists.geany.org/pipermail/devel/attachments/20210912/ee0d956c/attachment-0003.png>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: geany_windows_theme_default.png
Type: image/png
Size: 41288 bytes
Desc: not available
URL: <https://lists.geany.org/pipermail/devel/attachments/20210912/ee0d956c/attachment-0004.png>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: geany_windows_theme_win32.png
Type: image/png
Size: 41889 bytes
Desc: not available
URL: <https://lists.geany.org/pipermail/devel/attachments/20210912/ee0d956c/attachment-0005.png>

More information about the Devel mailing list