[Geany-Devel] Linker issues with VTE

Lars Paulsen lars_paulsen at xxxxx
Thu Feb 22 21:09:46 UTC 2018

Hi Lex,

it turned out I had not.

Then I installed it using apt-get install but Ubuntu only installed a 
version 0.42 which was older than required.

So I downloaded the sources and built it myself.
After that the error message about the missing "#include <vte/vte.h>" 
was gone.

But I got linker errors for calls to unresolved external function 
"vte_terminal_set_color_foreground_rgba". I assume this is some geany 
macro stuff. It turned out I can simply call 
"vte_terminal_set_color_foreground" because they changed the parameter 
from "GdkColor" to "GdkRGBA" - just what I needed.

So far vte issues seems to be solved.
Thanks to all for helping out again.


On 22.02.2018 09:08, Lex Trotman wrote:
> On 22 February 2018 at 16:11, Lars Paulsen <lars_paulsen at web.de> wrote:
>> Hello Colomban,
>> I saw that in the GTK3 porting PR for the debugger plugin and also tried
>> changing scope.m4 accordingly:
>> https://github.com/geany/geany-plugins/pull/645/files#diff-41e5fe75dcc03252ed3688fd124e9223
>> But if I do that my code does not compile cause it says "#include
>> <vte/vte.h>" not found.
>> I did not see any other build related changes regarding VTE in that PR so I
>> wonder what's missing.
>> Any ideas?
> Are you sure you have the -dev package for libvte2.9x installed, it
> doesn't seem to be needed to build GTK3 Geany (at least its not
> installed here and Geany's VTE works) but then Geany does some funny
> dynamic stuff with VTE so thats maybe why.
> Cheers
> Lex
>> Greetings,
>> Lars
>> On 21.02.2018 23:12, Colomban Wendling wrote:
>>> Le 21/02/2018 à 15:06, Lars Paulsen a écrit :
>>>> Hi All,
>>>> during porting the scope plugin to GTK3 I had to switch from "GdkColor"
>>>> to
>>>> <https://developer.gnome.org/gdk3/stable/gdk3-RGBA-Colors.html#GdkRGBA>"GdkRGBA".
>>>> The scope code was calling "vte_terminal_set_color_foreground" which
>>>> according to the geany header files seems to have a replacement  which I
>>>> called instead: "vte_terminal_set_color_foreground_rgba". Since I
>>>> replaced the call I get linker errors.
>>>> I saw that geany is creating the functions through a macro surrounded by
>>>> some version checks. I assume I have to change something on the build
>>>> parameters for geany to make it work. Please help.
>>> Don't touch Geany itself, only Geany-Plugins.  And you have to change so
>>> you use a GTK3 version of libvte with that function ("libvte2.90"
>>> package IIRC) and not the GTK2 version ("vte").
>>> Regards,
>>> Colomban
>>> _______________________________________________
>>> Devel mailing list
>>> Devel at lists.geany.org
>>> https://lists.geany.org/cgi-bin/mailman/listinfo/devel
>> _______________________________________________
>> Devel mailing list
>> Devel at lists.geany.org
>> https://lists.geany.org/cgi-bin/mailman/listinfo/devel

More information about the Devel mailing list