[Geany-Devel] geany plugins fails to compile with latest pango

Tim Tassonis stuff at xxxxx
Fri Nov 24 21:46:16 UTC 2017


Hi all

Pango recently switched from autotools/libtool to meson/ninja and it 
seems that geany-plugins can't handle that. The compile/install fails on:


/bin/sed: can't read /opt/X11/lib/libpangocairo-1.0.la: No such file or 
directory
libtool:   error: '/opt/X11/lib/libpangocairo-1.0.la' is not a valid 
libtool archive

Those files are not installed anymore with latest pango. Is there a fix 
or is pango with meson/ninja not supported?


Kind regards
Tim



More information about the Devel mailing list