[Geany-Devel] New plugin loader mechanisms

Colomban Wendling lists.ban at xxxxx
Sun Mar 29 16:39:51 UTC 2015

Le 26/03/2015 00:22, Thomas Martitz a écrit :
> […]
>> What if instead of PluginHooks it was called `Plugin` (GeanyPlugin is
>> taken, so for this discussion I'll use `Plugin` :) and instead of just
>> the callback function pointers it contained the (possibly
>> sub-)plugin's info, like this:
> Plugin is also taken inside Geany :)

Not really, it's internal and only shorthand for GeanyPluginPrivate. We
can very easily change this if we want.

More information about the Devel mailing list