[Geany-Devel] Proxy Plugins Update
dimitar.zhekov at xxxxx
Thu Jul 10 10:23:45 UTC 2014
On Wed, 09 Jul 2014 10:40:20 -0700
Matthew Brush <mbrush at codebrainz.ca> wrote:
> On 14-07-09 10:01 AM, Dimitar Zhekov wrote:
> > On Tue, 08 Jul 2014 20:16:49 +0200
> > Thomas Martitz <kugel at rockbox.org> wrote:
> >> My whole libpeas fork is (currently) imported into the geany repo so
> >> it's a bit academic.
> > I'd like to have a libpeas fork, or at least our own copy of the
> > library (the code is actually quite small). The latest libpeas
> > requires glib/gobject/gmodule/gio all >= 2.30, and the Debian package
> > even has gtk+3 as requirement because of libpeas-gtk, which is actually
> > optional and will not be used in Geany.
> You could use that point to recommend forking all of our dependencies,
> for example the latest GLib/GObject/GModule/GIO is >= 2.30 too, the
> latest GTK+ is 3.12 and requires GLib >= 2.39, the latest Pango requires
> GLib >= 2.32. We can't fork everything :)
These are shipped together as an official Windows binary, while libpeas
is not AFAIK (havent't searched too deeply). We don't want all Windows
users to compile peas to be able to use Geany.
> IMO, it'd be better just to depend on an older version than the latest
> like we do for everything else, and maybe open a bug report for the
> Debian package if it wrongly makes libpeas depend on libpeas-gtk instead
> of the other way around.
To use an unmodified package, we'll have to go back to version 1.2.0
or so, and check for any important bugfixes until the current 1.10.0.
We may end up with a de-facto fork.
libpeas-gtk is a subdirectory of libpeas, it's normally compiled with
the package, so the dependency is not wrong. The maintainer could have
chosen to make it a separate package, but did not.
I strongly suspect that libpeas (at least without the gtk+ widgets)
does not really require the g* >= 2.30. There haven't been any major
changes in the type system since glib _2.4_, and GTypePlugin is stable
even before that. It could be the developers simply place the current
g* versions as requirement.
More information about the Devel