[Geany-Devel] [Geany-Plugins] Please consider adding GTK3 support for your plugin(s)

Dimitar Zhekov dimitar.zhekov at xxxxx
Sun Mar 24 19:06:03 UTC 2013

On Mon, 18 Mar 2013 17:12:00 +0100
Colomban Wendling <lists.ban at herbesfolles.org> wrote:

> I forgot to mention that Geany now have a header called gtkcompat.h that
> gets included by geanyplugin.h which gives some GTK2/3 compatibility.
> This means you don't have to do the conditionals yourself for some
> things if you depend on Geany 1.24 (current Git): [...]

> * GtkComboBoxText API is available even with GTK < 2.24.

#define gtk_combo_box_text_new_with_entry gtk_combo_box_entry_new_text

IIUC, I should now be using gtk_combo_box_text_new_with_entry. And any 
attempt to compile geanyinsertnum with a Geany lacking gtkcompat.h will
require gtk 2.24 or later.

> * gtk_widget_set_can_default(),
>   [...]
>   are available even with GTK < 2.18.
> * gtk_widget_get_mapped() is available even with GTK < 2.20.

But only if you are compiling with the newest Geany. So we are either
dropping the plugin compatibility with Geany <= 1.23, or with GTK+ <=
2.22. Of course, one can compile the plugins with Geany-git, and use
them with a stable Geany... I doubt thing many people will bother.

Maybe we should make gtkcompat.h part of the geany-plugins package?
Or define the symbols in the reverse way?

E-gards: Jimmy

More information about the Devel mailing list