[Geany-devel] GTK+ Version Bump to 2.18
lists.ban at xxxxx
Mon Oct 17 16:22:15 UTC 2011
Le 13/10/2011 01:55, Matthew Brush a écrit :
> On 11-10-12 07:04 AM, Nick Treleaven wrote:
>> On 12/10/2011 02:58, Matthew Brush wrote:
>>> I've also been working on getting rid of some of the uses of sealed
>>> members (ex. widget->window as opposed to
>>> gtk_widget_get_window(widget)). It seems many of the accessor functions
>>> were added between 2.12 and 2.18. One of the functions that comes to
>>> mind that needs 2.18 and could be used in several places in Geany is
>> OTOH, those functions are trivial to support on < 2.18, if there were a
>> reason to prefer lower versions. If there's not too many.
> There's lots :) 
As Nick said, your link doesn't tell which ones requires 2.18 ;)
IMO it's not too hard to create a "compat" header that would define the
required accessors for version where they're missing. It's quite a
boring work but nothing complicated.
Anyway AFAIK there are lot of accessors that came in 2.24, and we
probably don't want to require bleeding-edge GTK2.
>>> So I was wondering if anyone was opposed to going from GTK+ 2.12 to 2.18
>>> as the minimum supported GTK+ version. IMO, if we are going to raise the
>>> version this release cycle, it makes sense to do so sooner rather than
>>> later to maximize the time for finding and fixing bugs and so on.
>> From my own POV I would prefer lower versions for now - I have 2.16 on
>> my main machine. I could update but I'm still reeling a little from the
>> github switch ;-)
> So the answer to my question in the other thread about what specifically
> sets the minimum GTK+ version Geany supports is: Whatever Nick is
> running :)
>> So I would go for 2.16 overall if this brings us Glade 3 support.
> It should, but I haven't thoroughly tested it with GTK+ 2.16 yet. Did
> you try the gtkbuilder branch yet on your 2.16 install by any chance?
> Anyway, I won't push for GTK+ 2.18 any more if some core Geany devs are
> against it.
I'm not against any GTK version (heh, I personally have 2.24 and 3.0
anyway ^^), but I think we shouldn't bump for no good reason. If we
need a new widget, or a new feature, OK, but if it's for 1 or 2
accessors and we anyway need some more that are only in even more recent
versions, it seems a bit pointless to me.
So 2.16 for GtkBuilder, yes. 2.18... I'm not sure, it depends on what
is the rationale for it.
More information about the Devel