[Geany-devel] GTK+ Version Bump to 2.18
nick.treleaven at xxxxx
Wed Oct 12 14:04:04 UTC 2011
On 12/10/2011 02:58, Matthew Brush wrote:
> Hi all,
> According to the recent discussions on the mailing list, its sounds like
> we could safely require GTK+ >= 2.18 and still support a lot of
> enterprise/LTS/legacy distros.
> You might've noticed I pushed my gtkbuilder branch into geany/geany. To
> use this requires GTK+ 2.16 since it seems this is where lots of the
> GtkWidgets that Geany uses started to implement the GtkBuildable
> interface. This is at least according to what I read and the complaints
> from Glade 3.
> I've also been working on getting rid of some of the uses of sealed
> members (ex. widget->window as opposed to
> gtk_widget_get_window(widget)). It seems many of the accessor functions
> were added between 2.12 and 2.18. One of the functions that comes to
> mind that needs 2.18 and could be used in several places in Geany is
OTOH, those functions are trivial to support on < 2.18, if there were a
reason to prefer lower versions. If there's not too many.
I would say Glade 3 support is important, but I'm not sure how important
GTK 3 support is yet.
> So I was wondering if anyone was opposed to going from GTK+ 2.12 to 2.18
> as the minimum supported GTK+ version. IMO, if we are going to raise the
> version this release cycle, it makes sense to do so sooner rather than
> later to maximize the time for finding and fixing bugs and so on.
From my own POV I would prefer lower versions for now - I have 2.16 on
my main machine. I could update but I'm still reeling a little from the
github switch ;-)
So I would go for 2.16 overall if this brings us Glade 3 support.
More information about the Devel