[Geany-devel] GTK+ Version Bump to 2.18

Matthew Brush mbrush at xxxxx
Wed Oct 12 01:58:40 UTC 2011

Hi all,

According to the recent discussions on the mailing list, its sounds like 
we could safely require GTK+ >= 2.18 and still support a lot of 
enterprise/LTS/legacy distros.

You might've noticed I pushed my gtkbuilder branch into geany/geany.  To 
use this requires GTK+ 2.16 since it seems this is where lots of the 
GtkWidgets that Geany uses started to implement the GtkBuildable 
interface.  This is at least according to what I read and the complaints 
from Glade 3.

I've also been working on getting rid of some of the uses of sealed 
members (ex. widget->window as opposed to 
gtk_widget_get_window(widget)).  It seems many of the accessor functions 
were added between 2.12 and 2.18.  One of the functions that comes to 
mind that needs 2.18 and could be used in several places in Geany is 

So I was wondering if anyone was opposed to going from GTK+ 2.12 to 2.18 
as the minimum supported GTK+ version.  IMO, if we are going to raise 
the version this release cycle, it makes sense to do so sooner rather 
than later to maximize the time for finding and fixing bugs and so on.

As a side topic; is there any way we can automate parts of changing the 
GTK+/GLib version numbers in all the various affected files?  I was 
thinking maybe a small Python/Perl script or Autoconf substitution or 
something like this.  It's just an idea that came to mind, it might be 

@Enrico: How much trouble does this cause for the win32 builds?  Is it 
just changing the Waf/makefile.win32 files and then packaging a newer 
GTK+ binary pack next release?

Matthew Brush

More information about the Devel mailing list