[Geany-devel] geany-plugins: Bug in translation

Enrico Tröger enrico.troeger at xxxxx
Thu Oct 6 20:51:50 UTC 2011

On Fri, 07 Oct 2011 00:44:58 +0400, Alexander wrote:

>06.10.2011 20:19, Frank Lanitz пишет:
>> On Wed, 05 Oct 2011 17:30:23 +0400
>> Alexander Petukhov<devel at apetukhov.ru>  wrote:
>>> just wanted to add more info:
>>> to easily see the effect try addons plugin and it's context menu
>>> "Open URI" and "Copy URI" menu items.
>>> Until some svn update, IIRC translations of my debugger and possibly
>>> other plugins were more
>>> complete, from some point I noticed that some strings become
>>> untranslated but then I decided
>>> that it was a bug in my plugin, and didn't pay much attention to it.
>> It looks a bit like its related to position of including of
>> geanyplugin.h. I guess I've fixed it for geany VC but needs some
>> further investigation.
>> [...]
>as I discovered the point is that you have to include config.h in
>every file that contains translatable strings, actually #define 
>GETTEXT_PACKAGE "geany-plugins" is the only line that is needed from
>it. Previosuly it worked without it somehow.
>if GETTEXT_PACKAGE is not defined, textdomain(NULL) returns NULL, i.e. 
>there is no textdomain set, with GETTEXT_PACKAGE it returns "messages" 
>while I expected to see "geany-plugins" here.
>I tried to understand how i18n is realized in Geany but I couldn't
>find any textdomain call in Geany sources.
>2Enrico: every plugin that do not include config.h in a file with 
>strings seems to be untranslated now. As I mentioned above it worked 
>without it earlier so I suppose other plugins can also miss this
>include and therefore be untranslated but I didn't check.
>So two ways so far:
>1. include config.h everywhere it is nessesary
>2. look up what has been broken till 0.20

Ah, thanks for investigation.
Then this is probably caused by the change to not automatically include
config.h in geany.h which happened some months ago (this was a change
in Geany where it was wrong before). Plugins just "used" that wrong
behaviour and now it shows how they are broken. So we probably need to
review each plugin again for this issue.

Any volunteers?  :)


Get my GPG key from http://www.uvena.de/pub.asc
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 198 bytes
Desc: not available
URL: <http://lists.geany.org/pipermail/devel/attachments/20111006/4043cca0/attachment.pgp>

More information about the Devel mailing list