[Geany-devel] backup pref - Re: Changed file saving implementation for systems with GIO
elextr at xxxxx
Tue Nov 23 21:50:35 UTC 2010
On 24 November 2010 03:27, Nick Treleaven <nick.treleaven at btinternet.com> wrote:
> On Fri, 19 Nov 2010 08:20:58 +1100
> Lex Trotman <elextr at gmail.com> wrote:
>> On 19 November 2010 06:04, Nick Treleaven <nick.treleaven at btinternet.com> wrote:
>> > On Mon, 15 Nov 2010 08:57:51 +1100
>> > Lex Trotman <elextr at gmail.com> wrote:
>> > I think either:
>> > 1. unsafe_save_backup should be renamed to gio_unsafe_save_backup to
>> > avoid confusion.
>> Ok, attached.
> Applied, thanks. I put the new pref field last just in case anyone is
> accessing the other fields from a plugin.
>> > 2. call the pref make_backup and make it work for all save
>> > implementations, and maybe have a GUI option for it.
>> To do this we would almost be writing the whole of GIO with the
>> algorithm I outlined previously. So we probably should do that
>> instead. For now lets just offer this easy option that provides
>> improved performance on remote filesystems.
> Fine with just the patch. I was only suggesting copying the
> existing file first for the backup when using non-gio saving.
Sure, what I realise I wasn't clearly saying is that when you *really*
need the backup is on remote filesystems, but then a copy costs you
two transfers on top of the one to save the file, too slow.
So you should try renaming first and only copy if you need to and by
the time you have done that you have reimplemented a poor version of
> Geany-devel mailing list
> Geany-devel at uvena.de
More information about the Devel