[Geany-devel] [Patch] Improvements to GTK+ class building

Colomban Wendling lists.ban at xxxxx
Tue May 11 20:17:43 UTC 2010

Hi there!

It was something I would do since a while, and there it is finally: making
the class builder plugin generate GTK+ classes that better follows GObject
naming conventions. I think of NAMESPACE_TYPE_CLASS_NAME instead of
The missing thing was mostly a separated namespace in facts.

Then, as usual there's a path. Oh no, two patches.

A very small patch that makes then plugin's menu document-insensitive. I
don't see any reason for the menu to be document sensitive, and it
obviously disallow to use the plugin when no document is open -- quite
strange since it only /crates/ files.

This one is the actual interesting stuff. What's in:
* namespace support (optional, leaving it empty works);
* GET_CLASS() macro;
* typedef of the private structure in the .h instead of declaring it;
* removing of the extra ";" at the end of G_DEFINE_TYPE().

-------------- next part --------------
A non-text attachment was scrubbed...
Name: 0001-classbuilder-no-document-sensitive.patch
Type: text/x-patch
Size: 344 bytes
Desc: not available
URL: <http://lists.geany.org/pipermail/devel/attachments/20100511/b3391e50/attachment.bin>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: 0001-classbuilder-gtk-class-improvements.patch
Type: text/x-patch
Size: 13425 bytes
Desc: not available
URL: <http://lists.geany.org/pipermail/devel/attachments/20100511/b3391e50/attachment-0001.bin>

More information about the Devel mailing list