( I think different user threads are getting mixed in some of these emails. Some simply have no application to my issue.)

"Have you tried running the script from a regular terminal (or even Geany's builtin terminal in the message window)?"

Perhaps I made this overly complicated.
My scripts work perfectly. I have fifteen of them for different current working library sets.
My scripts are not a problem. Those consoles/terminals work no problem. No blocking. Only when starting a console from geany.
I do not use F5 key.

When starting a new instance of geany, this is the command line:

    geany -i --config=/rdkl/.config/geany

I work from multiple systems; this helps keep them all the same.
Not perfect, but better.

Version is 1.27

"Because the output of build commands is parsed and displayed in the
compiler output tab only one build command can be running at a time or
their output will get mixed up and confused."

per geany instance only, right?

"So the build menu is blocked whilst a command is running.  So as I
said before, the command needs to start your terminal as a detached
process and exit immediately to get the menu back.  Did you try using
&? On *x commands are run in sh so it should work."

re: &  Yes, did that - no defference.

I have unchecked 'Load virtual terminal support'

I have unchecked 'msgwin_compiler_visible'
I have unchecked 'msgwin_scribble_visible'

Starting fresh this am:

Single instance of geany:
I re-enabled  'msgwin_compiler_visible'
Dropped geany
restarted - verified 'msgwin_compiler_visible' enabled

Looked at the debug messages screen - no sign of a problem.

Loaded one project. project build section looks like:

NF_03_CM=lxterminal --geometry=130x30& --working-directory=%d

My geany .config build section looks like:

NF_02_LB=file manager
NF_03_CM=lxterminal --geometry=130x30& --working-directory=%d&

click 'console' button in build drop down

compiler message window:

lxterminal --geometry=130x30& --working-directory=/rdkl/FB_common/defines (in directory: /rdkl/FB_common/defines)
/bin/sh: 1: --working-directory=/rdkl/FB_common/defines: not found
/usr/share/themes/Lubuntu-dark-panel/gtk-2.0/gtkrc:682: Unable to find include file: "apps/xfce4-notifyd.rc"

However, the terminal did start in the correct directory.

Leave this up, change desktop, open a second geany instance, load a profile, start a console

compiler message window:
lxterminal --geometry=130x30& --working-directory=/rdkl/FB_generic/rlib_small& (in directory: /rdkl/FB_generic/rlib_small)
/bin/sh: 1: --working-directory=/rdkl/FB_generic/rlib_small: not found
Compilation finished successfully.

console opened correctly
no status indicator, no build menu block

First instance of geany still up, console running, build menu blocked
drop console in that first instance, the status indicator stays, build menu still blocked.
Drop geany - reopen. (second geany instance still open)
drop console on second geany instance

Whichever geany I open a console on, it will block - the other will open correctly


On Thu, Jul 27, 2017 at 4:15 AM, Lex Trotman <elextr@gmail.com> wrote:
On 27 July 2017 at 19:47, Peter Koukoulis <pkoukoulis@gmail.com> wrote:
> Hi,
> a blank terminal appears with a heading of "geany_run_script_RCK23Y.sh", the
> last 5 characters before the suffix being random on each execution.
> The debug messages that appear around the time of execution are:
> "10:32:59: Geany INFO : Added filetype CUDA (65).
> 10:32:59: Geany INFO : Added filetype Cython (66).
> 10:32:59: Geany INFO : Added filetype Graphviz (67).
> 10:32:59: Geany INFO : Loaded libvte from libvte.so.9
> 10:32:59: Geany INFO :
> /home/mw/c++_Learn/learn2_c++/sqlapi/ora_ref_cursor.cpp : C++ (UTF-8)
> 10:32:59: Geany INFO : Loaded /usr/share/geany/tags/std99.c.tags (C), 1619
> symbol(s).
> 10:32:59: Geany INFO : /home/mw/c++_Learn/learn2_c++/sqlapi/ora_connect.cpp
> : C++ (UTF-8)
> 10:32:59: Geany INFO :
> /home/mw/c++_Learn/learn2_c++/sqlapi/pg_connect_test.cpp : C++ (UTF-8)
> 10:32:59: fcitx-connection DEBUG : _fcitx_connection_bus_finished"
> When I run the compiled and linked binary from a bash shell , then it
> executes as expected, but when executed with F5 from the geany the blank
> terminal appears. This is the behaviour in Lubuntu running in VirtualBox,
> but on Ubuntu it executes in geany as expected.
> There is no error message it seems.

If it runs "in Geany" (by which I assume you mean in the terminal
window) on one system and in an external terminal on another it sounds
very much like the run in VTE settings Matthew asked you to check are
different.  Please verify they are the same.


> Thanks
> On Thu, 27 Jul 2017 at 00:56 Matthew Brush <mbrush@codebrainz.ca> wrote:
>> On 2017-07-26 01:21 PM, Peter Koukoulis wrote:
>> > Hi
>> > I am running geany in both Ubuntu 17.04 (host) and Lubuntu (VirtualBox
>> > guest) 17.04 . My build settings are the same on both:
>> >
>> > compile : g++ -g -Wall -std=c++14 -c -lboost_thread
>> > -DBOOST_THREAD_VERSION=4 -pthread "%f"
>> > link: g++ -g -Wall -std=c++14  -o "%e" "%f"
>> > /home/bluefrog/SQLAPI/lib/libsqlapi.a -lpthread -pthread -lboost_thread
>> > -DBOOST_THREAD_VERSION=4 -lboost_system -ldl -lpq
>> >
>> > make Object: make %e.o
>> > Execute: "./%e"
>> >
>> > LD_LIBRARY_PATH is defined the same on both.
>> >
>> > When I execute (F5), having successfully compiled and linked, nothing
>> > appears in the terminal on Lubuntu in the VirtualBox, but when the same
>> > is
>> > executed  in Ubuntu (host), all appears as expected. Could somebody
>> > suggest
>> > what it may be?
>> >
>> It should give some kind of error in the status tab, or in the status
>> bar, or at least log something in Help->Debug Messages.
>> One thing that comes to mind is that the working directories aren't
>> right, but I would think that should print you some error somewhere. The
>> other thing is that maybe one of them is set to run the execute command
>> in Geany's builtin terminal and the other isn't (Preferences->Terminal:
>> [x] Execute programs in the VTE, and [x] Don't use run script).
>> Regards,
>> Matthew Brush
>> _______________________________________________
>> Users mailing list
>> Users@lists.geany.org
>> https://lists.geany.org/cgi-bin/mailman/listinfo/users
> _______________________________________________
> Users mailing list
> Users@lists.geany.org
> https://lists.geany.org/cgi-bin/mailman/listinfo/users
Users mailing list

If you don't try - you lose - automatically.