1) The file system is EXT4, so that wasn't the issue. Good thought, though.

2) It was the "no" that did it!

The value of "gio_unsafe_save_backup=no" is what made the difference. Since the default was "true," I expected the opposite to be "false." Guess that was my bad...



David Lee Crites, DevOps Dude
Cell: 806-471-9063
Skype: davidleecrites
quod alii ut vivere

-------- Original Message --------
Subject: Re: [Geany-Users] geany changing permissions on files when it
saves them.
From: Matthew Brush <>
Date: Sat, August 29, 2015 11:17 pm

On 15-08-29 10:41 PM, David Lee Crites wrote:
> Y'all;
> I am having an issue that is really starting to put me on edge. No matter what
> the perms are of a file, when geany saves it, they are 0644, period. It doesn't
> matter what type of file it is (shell script, txt file, perl, etc).
> I have done a complete uninstall and reinstall.
> I have looked through the previous bug reports and done some searches to see if
> others have had this issue. It appears to have been an on-going deal, with
> threads simply ceasing to continue and being closed after a while. I found, and
> tried the hints from:
> I have tried a number of combinations from the above web page, with no change.
> It is currently set to:
> use_gio_unsafe_file_saving=true
> use_atomic_file_saving=false (was true when installed)
> gio_unsafe_save_backup=false
> I have systematically attempted all 8 possibilities of the above three settings,
> with no change. I:
> * make the change
> * remove the file from the project
> * close the project
> * do a "completely uninstall" geany (using synaptic)
> * chmod the file (0750)
> * install geany (just geany and geany-common)
> * open the project
> * add the file to the project
> * change the file
> * save it
> * ls -l shows 0644
> Just for giggles and grins: umask is 0022. It is obvious this isn't the cause,
> or the perms would be 755 -- which I could deal with for the time being.
> I am currently using geany 1.23.1 on linux mint 14.04. I noted it was not the
> "latest and greatest," so I added the PPA to the system, and voila, the upgrade
> manager automagically upgraded me to 1.25.
> So I created a new project, added a bash script to it (original perms 0700),
> made a trivial change, and sure enough, the perms became 0644.
> I cannot continue to deal with having to reset the perms every time I edit a
> file. What needs to change? What do I have to do to force geany to quit
> resetting the perms to 0644?
> This started several months ago, but I thought it had something to do with my
> Vagrant configurations and the fact that I am working in 4 different OS/Version
> configurations. But today's testing has all been on one system (one which worked
> perfectly several months ago).
> Tips/tricks/pointers/answers appreciated!


Not really an answer but a data point. I'm using Geany 1.25 with Ubuntu
14.04 and I can edit/save executable bash scripts fine without messing
up the permissions. My settings are:


The only thing that comes to mind for your problem is that the file
system is not supporting permissions correctly (ex. FAT32, Samba, etc).

Matthew Brush
Users mailing list