Thanks for the quick responses! I regenerated the configure script as suggested:

gtk_modules="$gtk_package >= $gtk_min_version glib-2.0 >= 2.28"
gtk_modules_private="gio-2.0 >= 2.28 gmodule-no-export-2.0"

And it looks like most of this compiled! 

It failed here however because G_TYPE_KEY_FILE was not defined:
  CC     libgeany_la-geanyobject.lo

I tried hacking up a quick solution by putting this at the top of

#include <glib-object.h>
#define G_TYPE_KEY_FILE (g_key_file_get_type ())

but this caused a linker failure. 

libgeany sounds like a pretty important library so there's probably not a way for me to easily get around this. 

On Tue, Dec 6, 2016 at 10:50 PM, Matthew Brush <> wrote:
On 2016-12-06 08:00 PM, Asif Aaron Amin wrote:

When I try to build the latest geany (version 1.29) from source I get the
following configure error:

checking for GTK... no
configure: error: Package requirements (gtk+-2.0 >= 2.24 glib-2.0 >= 2.32
gio-2.0 >= 2.32 gmodule-no-export-2.0) were not met:

Requested 'glib-2.0 >= 2.32' but version of GLib is 2.28.8
Requested 'gio-2.0 >= 2.32' but version of GIO is 2.28.8

Is it possible to get past these constraints besides installing the latest
glib libraries? I'm currently using version 1.27 and I was able to build
from source flawlessly. I feel bad that I'm not using the bleeding edge
geany version anymore. Geany is my favorite text editor and I like to get
the new goodies from each new release!

You could change `2.32` here and the next line to `2.28.8` and then fix what breaks. I think it's not a lot that requires `2.32` [0].

Would it be possible to relax these constraints in future possibly?

I think it would be a valid Issue[1] to request re-synchronizing the GTK+ and GLib version numbers. If we only check for GTK+ `2.24.0` then we should probably only require GLib `2.27.3` like GTK+ itself (debatable).

Most likely a clean patch/pull request to resolve the mismatch would be accepted.

Matthew Brush


Users mailing list