C:\cygwin64\bin\gfortran -c "geany.f95" (in directory: C:\Users\mgaddipati\Desktop\Fortran\Hello)
C:/cygwin64/lib/gcc/x86_64-pc-cygwin/5.4.0/f951.exe: error while loading shared libraries: ?: cannot open shared object file: No such file or directory
Compilation failed.

I am getting this error when I do this


On Mon, Oct 31, 2016 at 4:59 PM, Matthew Brush <mbrush@codebrainz.ca> wrote:
On 2016-10-31 09:12 AM, manohar gaddipati wrote:

This is Manohar. I have a windows machine.
My objective here is to be able to use geany for fortran programming. This
is what I did so far.

1)    I have downloaded CYGWIN (installed fortran and some recommended
libraries) and geany.
2)   Created a sample test.f90 program. I can see different color fonts in
my program
3)   For source compilation I went to Build (set Build commands) and tried
this which did not work
     Under Compile (C:\cygwin64\bin  -c  "%f")
     Under Build (C:\cygwin64\bin -o  "%f")
     Under Execute (C:\cygwin64\bin\gfortran "%e")

I tried using online manual but I am missing something.

Could you suggest me on this?


The build and compile commands should probably refer to `C:\cygwin64\bin\gfortran` instead of just the bin directory and the execute command should probably just be `"%e"` (unless you need to use `gfortran` to execute programs, I don't think you do though).

  Compile: C:\cygwin64\bin\gfortran -c "%f"
  Build: C:\cygwin64\bin\gfortran -o "%f"
  Execute: "%e"

Matthew Brush

Users mailing list