Just dropping a line to tell you that I managed to get it working now. I changed my build options from:

g++ -Wall -o "%e" "%f"


g++ -Wall -g -o "%e" "%f"

It seems I had forgot to put the -g flag in with the build options ( i just put it in the compile options)

And it's working like a charm now! As to be expected it was my own damn fault :-)


2008/10/1 Mikael Nordin <mickewiki@gmail.com>

The simplest way is probably to open the appropriate source file in
Geany, place the cursor at the function or the source code line where
you want to add a break point, and then click on the 'Breaks' button of
the debug plugin.
That is exactly what I am trying to do :-)

It doesn't work  that way, and it doesn't work if I specify another line or function name manually either.

Since last time I have updated to Ubuntu Intrepid and I am now using the geany-package from the intrepid repository (still 0.14) with the debugger-plugin built from source (of course). The problem persists though. It doesn't matter if I specify a source-path to the source under the environment path either.

I've include a screen shot of the error message.

How ever I have now worked out that the problem is indeed there when I run gdb manually at the command line as well (which I didn't think initialy).

(gdb) b ~/c++/wikifind_rev/wikifind_rev.cpp: 85
No source file named ~/c++/wikifind_rev/wikifind_rev.cpp.

So I guess that the problem is related to gdb rather that the geany debugger-plugin.

And yes, I have checked my search paths and tried severaly diferent ways to specify the path: ~/ and /home/micke/ andso on.