I tried disabling all docs with this configure command:

./configure --prefix=$TRIXDIR --exec-prefix=$TRIXDIR --enable-the-force --enable-html-docs=no --enable-pdf-docs=no --enable-api-docs=no --enable-gtkdoc-header=no

I got less warnings but I still get the GLib-GObject-CRITICAL errors whenever I click on anything. Main functionality seem to be working very well however so the errors are a small price to pay for successfully hacking version 1.29 on my RHEL 6 OS. 

Perhaps in future releases yall should add this to  geanyobject.c ? (Psuedocode)

#if GLIB_VERSION < 2.32

Again thanks for all of your help!

On Wed, Dec 7, 2016 at 10:16 AM, Asif Aaron Amin <asifamin@utexas.edu> wrote:
YES! That worked!

I built without the -disable-gtkdoc-header flag and the compile still succeeded! I'm running version 1.29 right now but I'm getting spammed with a massive amount of these messages in the terminal:

(geany:23882): GLib-GObject-CRITICAL **: g_closure_ref: assertion `closure->ref_count < CLOSURE_MAX_REF_COUNT' failed

(geany:23882): GLib-GObject-CRITICAL **: g_closure_invoke: assertion `closure->marshal || closure->meta_marshal' failed

I'm going to try the configure with -disable-gtkdoc-header to see if that helps....

Thanks a lot! I REALLY appreciate it!

On Wed, Dec 7, 2016 at 10:00 AM, Matthew Brush <mbrush@codebrainz.ca> wrote:
On 2016-12-07 07:43 AM, Asif Aaron Amin wrote:

Thanks for the quick responses! I regenerated the configure script as

gtk_modules="$gtk_package >= $gtk_min_version glib-2.0 >= 2.28"
gtk_modules_private="gio-2.0 >= 2.28 gmodule-no-export-2.0"

And it looks like most of this compiled!

It failed here however because G_TYPE_KEY_FILE was not defined:
  CC     libgeany_la-geanyobject.lo

I tried hacking up a quick solution by putting this at the top of

#include <glib-object.h>
#define G_TYPE_KEY_FILE (g_key_file_get_type ())

but this caused a linker failure.

Do a search and replace of G_TYPE_KEY_FILE for G_TYPE_POINTER (all in geanyobject.c I think). The only reason G_TYPE_KEY_FILE is needed is because GObject-introspection is broken. You might need to pass --disable-gtkdoc-header to configure script as well.

Matthew Brush

Users mailing list