I'm using Geany 1.30.1 on Windows 7.

After happily editing a file over some time, suddenly Geany refuses to save it with this error message:

I know that Windows sometimes grabs a lock on a file when I'm just looking at it with another tool, but I am pretty sure that the only way I'm operating on this file since the last bootup of my machine, is by editing it in Geany. Still, for the safe side, I run the Handle utility to see whether someone has a handle to either the file or the directory where the file is in - nothing. I also used Geany's "File/Properties" to check, whether maybe the file secretly became readonly; this is also not the case. Finally I turned on the gio_unsafe_save_backup and tried again, but same result. Note that it is a local file, so there can't be network issues involved either.

Then I tried "save as" with "rename", to store it under a new name in the same directory. This was refused with the same error message. I could see that the file got renamed, but still had the old content. This is weird: If the cause would be a directory lock, the rename should ALSO have failed.

Needless to say that it is not a disk space problem either.

I resolved the problem temporarily by using the following strategy:

  1. Using "Save as" to save it to a completely different directory.
  2. Copying the file back (on the command line)
  3. Closing the Buffer in Geany
  4. Reopening it

I then checked with my remaining open files in Geany. Modifying the buffer and saving, caused the same error with two of the files, while it worked fine with two others. One of the two where the error occured too, belonged to a different directory, while all the others - including those which could be saved - belonged to the same directory as the file where the problem occured initially.

I don't see yet in what respect the two files which did not have the problem, differed significantly from the two files where the problem occured.

Closing Geany, starting it, and I can continue editing like normal, but my feeling is that it will be only a question of time until the problem occurs again. Is there anything I can do to help the Geany developers to nail down the cause of this strange problem?

You are receiving this because you are subscribed to this thread.
Reply to this email directly, view it on GitHub, or mute the thread.