kugel- requested changes on this pull request.
I think the commit message lacks a bit of story. Yes, the change fixes a TODO in the code but the message could mention just that.
@@ -2291,6 +2291,22 @@ static void build_load_menu_grp(GKeyFile *config, GeanyBuildCommand **dst, gint
}
+/* set GeanyBuildCommand if it doesn't already exist and there is a command */ +static void assign_cmd(GeanyBuildCommand *type, guint id, + const gchar *label, gchar *value) +{ + if (!EMPTY(value) && ! type[GBO_TO_CMD(id)].exists) + { + type[GBO_TO_CMD(id)].exists = TRUE; + SETPTR(type[GBO_TO_CMD(id)].label, g_strdup(label)); + SETPTR(type[GBO_TO_CMD(id)].command, value); + SETPTR(type[GBO_TO_CMD(id)].working_dir, NULL); + type[GBO_TO_CMD(id)].old = TRUE;
The readablity could be improved by using a temporary variable for `GBO_TO_CMD(id)` or even the whole `type[GBO_TO_CMD(id)`